Vous êtes ici:

Menu

Centreon 2.5x et PHP sur Debian

debian

Avis à tous les lecteurs, avant de m'écrire que vous ne pouvez pas modifiez votre configuration... Happy

Depuis que la distribution Debian est passée en version 7.x (wheezy), l'interface Web Centreon fonctionne mal avec la version PHP 5.4 installée par défaut. Ceci est dû au framework utilisé qui n'est pas totalement compatible avec PHP 5.4. Malheureusement, il n'est pas prévu de mise à jour de cette interface, car les développeurs de Centreon travaillent d'arrache-pied à la nouvelle version prometteuse qui aura une toute nouvelle interface. Ce rappel concerne toutes les internautes qui veulent se lancer dans l'installation d'une supervision Centreon à base de Debian, n'installez pas la version PHP 5.4 avec Wheezy !
L'installation de Centreon ne vérifie pas la version du PHP et elle se termine sans problème. Le plus troublant, vous pouvez vous connecter et lancez le démarrage de la configuration. Votre supervision fonctionne ! Mais viennent ensuite les dysfonctionnements lorsque vous voulez ajouter, modifier vos hôtes et services. Voici un exemple simple d'un dysfonctionnement lors d'un ajout d'un hôte ci-dessous :

erreur-add


Si vous obtenez cet exemple de vue quand vous validez votre modification, ne cherchez pas ! Vous n'avez pas la bonne version de PHP.

Deux solutions s'offrent à vous :
- La première, la plus radicale, réinstaller votre supervision en configurant le gestionnaire de paquet APT comme indiqué dans cet article.
- La deuxième, la plus délicate, downgrader le PHP comme indiqué dans cette article http://blog.wpkg.org/2013/06/20/downgrading-to-php-5-3-on-debian-wheezy-7-0/

Cette deuxième solution évite la réinstallation de votre supervision, je viens de la tester. Merci à Clément pour avoir trouvé cette solution sur Internet Winking

blog comments powered by Disqus
 Vous êtes ici: